Audacity 2.2.2

Audacity 2.2.2 was released on 20 February 2018.

Changes and improvements since previous version

See the New features in Audacity 2.2.2 page in the Manual for more information about improvements and other changes.

Dropout detection

New feature Dropout detection is controlled from a setting in Recording Preferences called "Detect dropouts".

  • When this setting is "on" (default setting) Audacity will detect dropouts (brief gaps in the recording) and will insert zeroes into the recording to keep the other good parts synchronized. These silent spans will make the dropouts more obvious, but keep the duration of the recording correct.

    • Dropouts may be caused by a disk drive that cannot keep up with the recording. This can happen, for example, with a slow USB or network drive, or if antivirus software is slowing writing to disk, or if other activity on the computer is slowing the computer down.

  • When recording stops, a Warning message is shown and a label track, called "Dropouts", is added showing the lost parts, labeled with consecutive numbers.

Improved zooming

Zooming with the mouse wheel

  • Mouse wheel zooming has been changed so that the focus for the zoom is:

    • With the mouse pointer outside the selection, the leftmost or rightmost edge of the current selection, (if a selection exists).

    • Mouse pointer position will be used as the zoom focus if the mouse position is inside the current selection, (if a selection exists).

    • If no selection is present, zoom focus is as it was before and is taken as the mouse pointer position.

Zoom Toggle

  • A new command has been introduced, Zoom Toggle, accessed by a new button or by View > Zoom > Zoom Toggle (shortcut Shift + Z).

    • Zoom Toggle toggles between two pre-defined zoom levels. These presets are user selectable in Tracks Preferences.

    • Defaults are normal Default Zoom level and 4 Pixels per Sample (which shows a fraction of a second of audio as samples)

    • Either of the two presets can be changed in Tracks Preferences using the dropdown menus.

Vertical Zooming changes

  • Simple Vertical Scrolling

    • A context menu has been introduced for the Vertical Scale. This is activated by right-clicking in the Vertical Scale.

  • Advanced Vertical Zooming

    • Left-click, and click&drag, in the Vertical Scale remain available as a user-selectable option. The default setting is "off",

    • You can turn on advanced mode for vertical zooming from Edit > Preferences > Tracks Behaviors and selecting Advanced Vertical Zooming.

Extra menu

A new Extra menu has been created from consolidating the Ext-Bar and Ext-Command menus that were introduced in the previous 2.2.1 release.

Theme tweaks

  • Hover Appearance

    • In dark theme, the change in appearance of sliders when you hover over them is greater than before.

    • In light and dark themes, buttons such as 'pause' and 'pin' now highlight when you hover over them and they are down. Previously there was no visible change.

    • The hover effect for buttons when they are up has been changed to work better in conjunction with this change.

  • Icon Appearance

    • In dark theme the microphone and speaker icons are now brighter and not dulled as they were before.

Other Changes

  • For menu commands that are enabled (not grayed-out) if you hold the Shift key and click on the sub-menu item, instead of executing the command the Keyboard Preferences pop open at the chosen command. You can then change that (or any other) shortcut binding.

  • Interface Preferences has been upgraded so when selecting languages the proper spelling of these languages is shown with accented and special characters.

  • The Index page in the Manual has been upgraded - so that now any item that can be clicked on/through in the front page imagemap now has a corresponding text entry in the index (this is primarily as an aid to VI (Visually Impaired) users) Additionally the Index has been divided into alphabetic sections to aid readability.

Bug Fixes

  • Multiple use of "Save As" to the existing open project can result in data corruption/loss

  • Crash undoing during record, using Discard button of History window

  • Exporting audio in compressed formats to device with insufficient space produces inconsistent/truncated results

  • In Export Multiple, Cancel does not remove the file that is in progress when Cancel is chosen

  • Crash using SBSMS pitch change at low sample rate

  • Installer has old logo for 2.2.1 and 2.2.0

  • (Mac) Equalization: "Telephone" curve displays a flat line, no sound on Preview

  • Toolbars: open undocked if previously not shown, unless Reset Toolbars first

  • Analysis effects that create labels should give focus to label track

  • Control value may be out of range when using FloatingPointValidator

  • Analysis effects produce false indication that a label is open for editing

  • Import Uncompressed File Dialog Incorrect Reference to Menu Item

  • Wave Color not grayed out in TCP dropdown menu when in Spectrogram view

  • Hover indication on note track channel toggle appears on all tracks (when they rerender)

  • Unicode page encodings fixed ( อกยฐ อœส– อกยฐ)

  • Un-muting with a single track unnecessarily activates the Solo button

  • Applying chain to file should zoom-to-fit

Supported Platforms

Windows

  • Audacity 2.2.2 requires the CPU to support the SSE2 instruction set which should be available on any Intel hardware produced after 2001 and any AMD hardware produced after 2003. To check what SSE levels your CPU supports, you can install CPU-Z. If your hardware only supports SSE, you may download Audacity 2.0.6 see the Legacy Windows page on the Audacity Website.

  • 2.2.2 does not officially support Windows XP.

macOS / Mac OS X

Linux

  • Linux support is tested on Ubuntu Linux.

    • Audacity may compile on Gentoo, Debian, Mint.

    • Audacity does not currently compile on SuSE Linux.

Issues

  • Below are listed what we believe are the most common and important issues with 2.2.2 for most users.

Accessibility

Bugzilla

We track these and many other bugs in our 'bugzilla' database.

Click on the bug numbers to see work done on these bugs.

ID

Summary (3 tasks) โ‡’

ID

Timer Record occasionally carries on recording past the scheduled end, requiring force quit

Linux: PULSE-AUDIO issues. Freeze repeatedly starting/stopping streams

Using File > Open to import audio gives wrong zoom level and no scroll bar slider

Last updated

Logo

ยฉ Muse Group & contributors. Contents licensed under the Creative Commons-Attribution 4.0 license.